try to update with telnet
Code:
apt-get update
ap-get dist-upgrade